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1.0    The Menus
These menus are associated with the Main program:

    1.1    The File Menu
    1.2    The Turn Menu
    1.3    The Units Menu
    1.4    The Assault Menu
    1.5    The Reinforce Menu
    1.6    The Status Menu
    1.7    The Display Menu
    1.8    The AI Menu
    1.9    The Special Menu
1.10    The Options Menu
1.11    The Help Menu



1.1    The File Menu

The File Menu is used to start a new battle and to load and save previously 
created battles.
To start a new battle, select the New menu item. A dialog will be displayed 
allowing the scenario file to be selected.
To save the current battle, select the Save menu item. By default, battle 
files are saved with the .btl filename extension.
To save the current battle under a different filename, select the Save As 
menu item.
A recorded battle can be replayed by selecting the Replay menu item. A 
dialog will be displayed allowing the replay file to be selected. By default, 
replay files have the .btr filename extension. A Battle Replay can be 
paused once started by pressing the Escape key. The Restart Replay option
of the Special Menu is used to restart the replay.
To exit the Main program, select the Exit menu selection.



1.2    The Turn Menu

Selecting the Next menu item causes the current player turn to end and 
the battle advanced to the next player turn.



1.3    The Units Menu

Selecting the To Top menu item moves the selected units to the top of the 
stack.
Selecting the To Bottom menu item moves the selected units to the bottom
of the stack.
To load units, first select both passenger and carrier units and then select 
the Load/Unload menu item. To unload units, select the carrier unit and 
then select the Load/Unload menu item.
The Toggle Digging-In menu item toggles the Digging-In status of the 
selected units.
The Double-Time menu item initiates Double-Time movement for the 
selected units.
The Save AP's for Firing menu item causes the number of Action Points 
required to fire to be set aside for the selected units.
The Save AP's for Unloading menu item causes the number of Action Points
required to unload to be set aside for the selected units.
Selecting the Turn Clockwise menu item causes the selected units to turn 
clockwise.
Selecting the Turn Counterclockwise menu item causes the selected units 
to turn counterclockwise.
Selecting the Air Attack menu item causes an Air Attack to be initiated on 
the current Hot Spot hex.
Selecting the Artillery Dialog menu item displays the Artillery Dialog so 
that artillery units can be fired.
Selecting the Remove From Map menu item causes the selected units to be
removed from the map. Units to be removed from the map must be on the 
boundary of the map.
Selecting the Undo Last Movement menu item causes the last movement 
of units to be undone. Note that movement cannot be undone if Fog-Of-War
is in effect for the other side.



1.4    The Assault Menu

Selecting the Clear Assault menu item will reset an assault on the map that
has not been resolved.
Selecting the Add To Assault menu item will cause the currently selected 
units to be added to the current assault.
Selecting the Resolve Assault menu item will resolve the current assault.
The Show Odds menu item will display the combat odds associated with 
the current assault prior to its resolution.



1.5    The Reinforce Menu

To view the reinforcements scheduled to appear in the current battle, 
select the Scheduled menu item.
To view reinforcements which have showed up and are ready to be placed 
on the map, select the Arrived menu item.
To view the list of Fixed-Unit Releases, select the Releases menu item.



1.6    The Status Menu

Selecting the Scenario Information menu item displays a dialog with 
various information about the current scenario such as title, maximum 
visibility, ground conditions, and number of turns.
To view the current strengths of each side, select the Strength menu item.
To view a list of objectives and their current owner, select the Objectives 
menu item.
To view the current victory conditions, select the Victory menu item.



1.7    The Display Menu

Selecting the Units Off menu item causes the units on the map to be 
hidden so that the underlying terrain can be viewed better.
Selecting the Unit Bases menu item toggles the display of bases on the 3D 
units.
Selecting the Specials On Top menu item toggles the display of special 
counters on the top of each stack in the 2D view.
Selecting the Objectives menu item toggles the display of objective hexes 
on the map with ownership designations.
Selecting the Locations menu item displays the Location Dialog.
Selecting the Visible Hexes menu item shades the hexes which are not 
visible from the current Hot Spot hex.
Selecting the Reachable Hexes menu item shades the hexes that cannot be
moved to by the currently selected unit.
Selecting the Find Org menu item displays the Organization Dialog.
Selecting the Jump Map menu item displays the Jump Map.
Selecting the Hex Contours menu item toggles the drawing of hex contours
which help visualize elevation changes on the map.
Selecting the Opaque Infobox menu item toggles the drawing of the 
Infobox with an opaque background to improve legibility.
The Highlight submenu contains several selections for identifying certain 
units on the map.
Selecting the Spotted Units menu item highlights units that are currently 
spotted on the map.
Selecting the Fired/Fought Units menu item highlights units that have 
either fired or conducted assaults in the current turn.
Selecting the Moved Units menu item highlights units that have moved in 
the current turn.
Selecting the Disrupted Units menu item highlights units that are currently 
disrupted.
Selecting the Indirect Fire Units menu item highlights units capable of firing
using Indirect Fire.
Selecting the Anti-Aircraft Units menu item highlights units capable of firing
using Anti-Aircraft Fire.
Selecting the Organization menu item highlights all units belonging to the 
same organization as the currently selected unit.
Selecting the Mine Clearing Units menu item highlights all units that can 
clear mines.
Selecting the Leaders menu item highlights all leaders on the map.
Selecting the Headquarters menu item highlights all headquarters units on 
the map.



Selecting the Fixed Units menu item highlights all fixed units on the map.
Selecting the 2D Normal View, 2D Zoom-Out View, 3D Normal View, 3D 
Zoom-Out View, or 3D Extreme Zoom-Out View displays the corresponding 
map view.
Selecting the Rotate Map menu item rotates the map 180 degrees.



1.8    The AI Menu

Each side can be set to Manual, Computer, or Computer with Fog-of-War AI.
Under Manual AI, all actions are taken by the user. Under Computer and 
Computer with Fog-of-War, the computer moves and fires all units for the 
selected side. Under the Fog-of-War option, the opposing side can only see 
enemy units that are visible from one or more of their units. Selecting the 
Manual, Computer, and Computer with FOW menu items sets the AI for the
corresponding side.
The Activate AI menu item starts and stops the execution of the AI for the 
current side.
The Set Advantage menu item displays the Advantage Dialog.



1.9    The Special Menu

The Special Menu is used to select options for network play.
Selecting the Modem Host option selects the current computer as the Host 
computer for Direct Play(tm). The user will be prompted for the connection 
type based on the configuration of the computer system. If the user plans 
on selecting the TCP/IP connection type, they should first determine their IP
address using the WINIPCFG utility. Callers will need to know the IP address
of the Host computer. If Modem Host is already selected, selecting it again 
will disconnect the computer from the connection.
Selecting the Modem Caller option establishes the current computer as the 
caller computer for Direct Play(tm). The user will be prompted for the 
connection type and session on the Host computer. If the user plans on 
selecting the TCP/IP connection type, they should already know the IP 
address of the Host computer (see Modem Host option). If Modem Caller is 
already selected, selecting it again will disconnect the computer from the 
connection.
The Play By E-Mail option enables Play By E-Mail battles to be started and 
continued. Once this option is set, the user should either start a new 
scenario using the New option or continue an existing battle using the 
Open option of the File Menu. By default, PBEM battle files have the .bte 
filename extension.
The Two-Player Hot Seat option enables two players to play a battle at the 
same computer with FOW for each side during their turn. Once this option 
is set, the user should either start a new scenario using the New option or 
continue an existing battle using the Open option of the File Menu. By 
default, Two-Player Hot Seat battle files have the .btt filename extension.
The Record Battle option can be used to record a battle played either 
manually or against the computer. A file recording the battle is saved in a 
file with filename extension .btr. Selecting the Record Battle option a 
second time terminates the recording. Battle replay files can be replayed 
using the Replay option of the File Menu.
The New Encryption Key menu item can be used by the Modem Caller to 
specify a new string to be used to encrypt battle files on the Modem Host 
computer.
The Restart Replay menu item can be used to restart a Battle Replay that 
was paused by pressing the Escape key.
The Communication Dialog menu item Can be used to redisplay the 
Communication Dialog after it has been closed. The Communication Dialog
is only available during Modem play.



1.10    The Options Menu

Settings under the Options Menu are saved in the Windows Registry and 
restored the next time the Main program is executed.
The Prompt for Scenario option causes the Main program to prompt the 
user for a new scenario when the Main program is executed directly 
without going through the East Front front-end application.
The Beep on Error option causes the Main program to beep when an error 
is made by the user.
The Hide 3D Hot-Spot option causes the 3D hot spot outline to be hidden.
The Blink Hot-Spot option causes the 2D hot spot outline to blink. Note: the
3D hot spot outline does not blink even when it is visible.
The Auto Scroll option causes the map to automatically scroll when the 
mouse is moved to the screen edge. Otherwise, standard Windows scroll 
bars are displayed.
The Smooth Scroll option causes the map to scroll through all intermediate 
hexes when it is repositioned. Otherwise, the map is immediately redrawn 
at the new location.
The Hex Outlines option causes hex outlines to be drawn on the map.
The Sound Effects option causes combat sound effects to be played during 
battle.
The Background Music option causes background music to be played 
during a battle.
The Background Sound option causes background combat sound effects to 
be played during a battle. Note that this option and Background Music 
cannot both be enabled simultaneously.
The Graphical Icons option causes graphical icons to be displayed on 
counters in 2D modes. Otherwise, schematic NATO-style icons are drawn.
The Unit List option causes a list of units in the current Hot Spot hex to be 
displayed along the right-hand side of the screen. Otherwise, units are 
displayed using the Infobox.
The Auto Save option causes the current battle file to be automatically 
saved at the end of every turn not under AI control.
The Auto Save AP's for Firing option causes the Action Points required to 
fire to be set aside for each unit at the beginning of each player turn.
The Details submenu controls the level of detail associated with reports 
and information generated the game. Higher levels of detail increase the 
amount of information reported to the user.
The Initial View submenu controls the initial map view when the Main 
program is first executed.
The Last View option causes the map to be redisplayed the same as the 
last view when the Main program was last exited.



The 2D Normal View, 2D Zoom-Out View, 3D Normal View, 3D Zoom-Out 
View, and 3D Extreme Zoom-Out View options select the initial view for the
Main program correspondingly.
The Optional Rules menu item displays the Rule Dialog.



1.11    The Help Menu

The General Help menu item displays this help file.
The Unit Handbook menu item displays the Unit Handbook help file.
The Parameter Data menu item displays the Parameter Data help file.
The About menu item displays information concerning the East Front 
version and copyright.



2.0    The Dialogs
These dialogs are associated with the Main program:

    2.1    The Target Dialog
    2.2    The Artillery Dialog
    2.3    The Strength Dialog
    2.4    The Victory Dialog
    2.5    The Objective Dialog
    2.6    The Advantage Dialog
    2.7    The A/I Dialog
    2.8    The New Scenario Dialog
    2.9    The Arrived Dialog
2.10    The Schedule Dialog
2.11    The Release Dialog
2.12    The Jump Dialog
2.13    The Organization Dialog
2.14    The Location Dialog
2.15    The Rule Dialog



2.1    The Target Dialog

The Target Dialog appears whenever fire is directed into a hex where there 
is more than one potential target. Selecting a target unit and clicking OK, 
or double clicking on a target unit causes the fire to be directed at that 
unit.



2.2    The Artillery Dialog

The Artillery Dialog can be used to direct Indirect Fire during a players turn.
Selecting a unit in the dialog and right clicking on the map causes the unit 
to fire at the selected map hex. Units which are in range of the selected 
artillery unit are highlighted on the map. Clicking on the Locate button, or 
double clicking on an artillery unit causes the map to scroll to the artillery 
unit location.



2.3    The Strength Dialog

The Strength Dialog lists the units which are on the map for each side. 
Associated with each unit type is the number of units of that type and the 
Victory Points associated with that unit.



2.4    The Victory Dialog

The Victory Dialog is used to display the current victory conditions. Victory 
Points are calculated based on the objectives held by the first side in the 
scenario. Depending on the total victory points, the first side is awarded a 
Major Defeat, Minor Defeat, Draw, Minor Victory, or Major Victory.



2.5    The Objective Dialog

The Objective Dialog can be used to list the objectives of the current 
battle, their ownership, and victory points. Clicking on an objective in the 
dialog causes the map to scroll to the objective hex.



2.6    The Advantage Dialog

The Advantage Dialog can be used to display, and perhaps modify, the 
current Advantage Value of the current battle. Note: the Advantage Value 
of Play-By-E-Mail and Modem Play battles cannot be changed after the 
battle has started.



2.7    The A/I Dialog

The AI Dialog is used to select the AI setting of each side in a new battle 
and to select any Advantage Value. The AI setting of a side can be Manual, 
in which case the player moves and fires the units for that side, or 
Computer, in which case the computer moves and fires the units for that 
side. In addition, for a side controlled by the computer, the Fog-Of-War 
option can be set which prevents the player from seeing enemy units on 
the map that are not visible by friendly units.
Setting the Advantage Value to a value other than 0 gives that side an 
advantage in combat and the other side a corresponding disadvantage.



2.8    The New Scenario Dialog

The New Scenario Dialog is used to make selections under special play 
modes such as Modem play or Play-By-E-Mail. The local user can select 
which side they wish to play and if Fog-of-War should be in effect during 
the battle. Note that the Advantage value can be set in this dialog, but not 
changed during the course of battle.



2.9    The Arrived Dialog

The Arrived Dialog is used to display units which have arrived as 
reinforcements and to place those units on the map. Selecting an entry in 
the Arrived Dialog causes the map to scroll to the arrival location. Double 
clicking on the entry causes the units to be placed on the map.



2.10    The Schedule Dialog

The Schedule Dialog displays a list of reinforcements for the current 
scenario. Associated with each reinforcement entry is an arrival location, 
an arrival turn, and a probability of arrival at that time. If the probability is 
less than 100%, then the reinforcement may not arrive at the exact arrival 
turn, but may arrive at a later time. An asterisk (*) preceding the 
reinforcement entry indicates that the reinforcement is late in arriving. 
Selecting a reinforcement entry causes the map to scroll to the entry hex. 
Double-clocking a reinforcement entry displays a list of the units in that 
reinforcement.



2.11    The Release Dialog

The Release Dialog displays a list of Fixed-Unit releases for the current 
scenario. Associated with each release is a turn and a probability that the 
release will be applied at that time. If the probability is less than 100%, 
then the release may not be applied at the exact time noted, but may be 
applied at a later time.



2.12    The Jump Dialog

The Jump Dialog displays a reduced version of the current map. Units 
which are visible on the map are indicated and the current visible portion 
of the map is indicated by a red rectangle. Clicking on any portion of the 
map causes the map to be repositioned at that location.



2.13    The Organization Dialog

The Organization Dialog displays the organizations associated with the 
current battle. Selecting an entry in this list causes the units in this 
organization to be highlighted on the map. Clicking OK causes the dialog to
be dismissed and the highlighting to remain while clicking Cancel causes 
the highlighting to be removed.



2.14    The Location Dialog

The Location Dialog displays a list of map locations. Clicking on an entry in 
this list causes the map to scroll to that location.



2.15    The Rule Dialog

The Rule Dialog displays the settings for the Optional Rules currently in 
effect for a battle. Note that Optional Rules can only be changed at the 
beginning of a battle and not after it has started.



3.0    Other Features
These features are associated with the Main program:

    3.1    Hot Keys
    3.2    Min-Path Algorithm
    3.3    Optional Rules



3.1    Hot Keys

These hot keys can be used in the Main program:
F1 - Open Main program help file
F2 - Open Unit Handbook
F3 - Open Scenario Parameter Data help file
F12 - Toggle continuous mode
Keyboard 1 - Display in 3D Normal mode
Keyboard 2 - Display in 3D Zoom-Out mode
Keyboard 3 - Display in 3D Extreme Zoom-Out mode
Keyboard 4 - Display in 2D Normal mode
Keyboard 5 - Display in 2D Zoom-Out mode
Number Pad 0 - Load/unload units
Number Pad 1 - Move selected units down and left
Number Pad 2 - Move selected units down
Number Pad 3 - Move selected units down and right
Number Pad 4 - Turn selected units counter-clockwise
Number Pad 5 - Initiate air attack on current Hot Spot hex
Number Pad 6 - Turn selected units clockwise
Number Pad 7 - Move selected units up and left
Number Pad 8 - Move selected units up
Number Pad 9 - Move selected units up and right
Delete - Turn selected units counter-clockwise
Next - Turn selected units clockwise
Home - Move selected units forward in hex
End - Move selected units backward in hex
A - Display Arrived Dialog
C - Toggle display of map contours
F - Display Release Dialog
H - Display hexes reachable by currently selected units
I - Display scenario information
M - Toggle display of program menu
N - Advance to next unit to move or fire
O - Toggle display of objectives
P - Advance to previous unit to move or fire
R - Rotate map 180 degrees
S - Display Schedule Dialog
T - Toggle display of on-map thermometers
U - Toggle display of Unit List



V - Display hexes visible from current hot spot
X - Exit Main program
Up Arrow - Scroll map up
Down Arrow - Scroll map down
Right Arrow - Scroll map right
Left Arrow - Scroll map left
Space Bar - Recenter map on current Hot Spot hex



3.2    Min-Path Algorithm

There are three implementations of the Min-Path Algorithm in the game. 
Each has characteristics in terms of speed and accuracy.
When a unit is moved by the player, the default Fast Min-Path Algorithm is 
used. This implementation attempts to find a Min-Path to the destination 
hex subject to the restriction that the distance from the intermediate hexes
of the path to the destination hex must not exceed the distance from the 
unit to the destination hex. The goal of this restriction is to avoid wild 
detours to the destination hex that may be unexpected and totally 
unwanted by the player. For example, in a river crossing situation, if the 
main bridge is currently unable to accommodate more units, then a pure 
Min-Path could end up moving the unit a great distance away from the 
main bridge so as to reach a secondary bridge over the river. If the Fast 
Min-Path Algorithm is unable to find a path, then the player is told that 
there is no "Direct Path" to the destination hex.
A generalization of the default Min-Path Algorithm that looks for small 
detours to the destination hex is also available to the player. This 
algorithm, the Slow Min-Path Algorithm, takes longer than the default 
algorithm but will consider small detours in order to find paths around 
obstructions such as rivers. This algorithm is invoked by holding down the 
Alt key when the unit is moved.
The Slow Min-Path Algorithm is also the basis for Organization Moves. To 
perform an Organization Move, first highlight the organization to be moved
and then select the destination hex for the organization by holding down 
the Alt key and clicking with the right mouse button. The Organization 
Move will move each unit of the organization in turn towards the 
destination hex.
Finally, a pure implementation of the Min-Path Algorithm is used when the 
Reachable Hexes of a unit are displayed (see the Display Menu). This 
algorithm takes much longer than the other two but will find the absolute 
Min-Path to all hexes within the movement allowance of the unit. If a unit is
moved while the Reachable Hexes are displayed, then the Min-Path found 
by this algorithm is used to move the unit.



3.3    Optional Rules

These Optional Rules can be established at the beginning of a battle. 
However, once set, they cannot be changed during the battle.
Indirect Fire By The Map - Under this rule, Indirect Fire can be targeted at 
hexes that are not currently spotted by friendly units. However, such fire 
has reduced effectiveness and is subject to drift.
Extreme Fog-Of-War - This rule affects Fog-Of-War effects. When in effect, 
additional information is hidden from the opposing player such as the 
name of enemy units, their morale, and their strength (except in Open 
hexes). In addition, when the opposing side has Extreme Fog-Of-War, then 
the arrival probability and release probability of friendly units is not 
reported.
Armor Facing Effects - Under this rule, Direct Fire against Armored targets 
is affected by the facing of the target unit. Fire which is directed through 
the three facing hexsides of the target unit is reduced by 20%. Fire which is
directed through the two rear flank hexsides of the target unit is increased 
by 30%. Finally, fire which is directed through the rear facing hexside of the
target unit is increased by 100%.




